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UEFI Systems - Keyboard entry issue when starting system after full disk encryption - Kennisbank / ESET Endpoint Encryption - ESET Tech Center

UEFI Systems - Keyboard entry issue when starting system after full disk encryption

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Problem

When starting a system after Full Disk Encryption, keyboard input is either not possible or produces unexpected results.

Examples of this behaviour are detailed below:

  • Keyboard not responding to input
  • Shift or Caps Lock key presses inserting characters in password entry
  • Individual key presses filling username or password entry with the pressed character
  • Special characters (@,",! etc.) unable to be entered
  • Additional space characters being added on entries

The problem is caused by specific machine models.  The following devices have shown some of these behaviours: HP EliteBook Revolve 810 G3, ASUS ROD GL552VM, Microsoft Surface 2, Dell Inspiron 5000, Gigabyte B85M-D3H.

This problem has been seen with the current v4.8.3 DESlock+ client release.

This report relates only to systems that are using the UEFI boot method.  You can verify this by looking at the upper right corner of the DESlock+ pre-boot screen.  If it shows a version number that has two decimal places and ends in a U character then the system is booting using UEFI, e.g. 2.3.24U

 

Cause

This issue is caused by an incorrect implementation of the keyboard handler within the UEFI firmware of the computer.

 

Solution

To resolve this issue:

Download install v4.8.4 or later which can be found here: DESlock+ Download Page.

Please use this link to create a ticket if further assistance is required: KB213 - How do I create a DESlock+ Support ticket?

 

 

Related articles

KB325 - Toshiba / HP - system does not boot following full disk encryption

 

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