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My keyboard isn't working properly at the FDE login screen - Kennisbank / ESET Endpoint Encryption - ESET Tech Center

My keyboard isn't working properly at the FDE login screen

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Problem

Your keyboard is not responding when using the Full Disk Encryption Pre-Boot screen as pictured below.

In all cases, you should make sure you have the latest version of the client software, to check please see our article below:

KB27 - How do I find which version of DESlock+ is installed?

If you don't currently have the latest version of DESlock+, please see our articles below: 

KB203 - How to upgrade DESlock+ (managed)

KB209 - How to upgrade DESlock+ (standalone)

 

Cause

I have a Bluetooth keyboard

  • Bluetooth keyboards cannot be used in the full disk encryption (FDE) login screen due to the required bluetooth stack not running until Windows starts.

I have a Wireless keyboard

  • If your Wireless keyboard isn't responding, this may be caused by your BIOS settings not being set to allow Legacy USB Emulation.

I have a Docking keyboard

  • If you have a docked keyboard that isn't responding, this may also be caused by your BIOS settings not being set to allow Legacy USB Emulation.

Solution:

You may need to ensure that the BIOS settings allow Legacy USB Emulation. If not, you should use an external keyboard or enquire with your manufacturer as to whether your device supports your keyboard at Pre-Boot in the BIOS.

I have a Touchscreen keyboard

  • If you have a device that has a touchscreen e.g. (Microsoft Surface devices) and other touch based input PCs, you should enquire with your manufacturer whether your device supports this feature at Pre-Boot in the BIOS.

I have an External Keyboard

  • If your physically connected keyboard isn't responding:

In some cases a particular BIOS configuration will attempt to speed up machine boot times by missing out USB initialisation. This is commonly labelled as Fast Boot, however this may be termed differently depending on the manufacturer. Other terms include but not limited to: Quick BootUSB emulationPort InitialisationDevice Initialisation.

Solution:

In many cases Fast Boot can be disabled from within the BIOS settings as shown in the images below. 

note: You may find a slight increase in boot times due to disabling this feature as your BIOS will not skip other initialisation tasks.

 

If your physically connected keyboard is missing special characters e.g. (@#£%&^)

Solution:

You should check your keyboard layout and ensure your BIOS is up to date. Please see our articles below:

Keyboard layout - How to start a system that is Full Disk Encrypted

Can I upgrade the BIOS of a machine that has DESlock+ installed?

 

If you're still experiencing issues with your keyboard

Please submit a support ticket here: KB213 - How do I create a DESlock+ Support ticket?

 

Related articles:

KB343 - UEFI Systems - Keyboard entry issue when starting system after full disk encryption

KB283 - Keyboard Layouts supported by DESlock+ Pre-boot Authentication (Bootloader)

KB284 - DESlock+ Pre-boot Authentication Keyboard Support

KB228 - Using DESlock+ with Microsoft Surface devices

 

 

 

 

 

key words: keyboard unresponsive isn't responding can't type special characters

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